当前位置: 首页 > news >正文

【PAT甲级 - C++题解】1125 Chain the Ropes

✍个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1125 Chain the Ropes (pintia.cn)
🔑中文翻译:结绳
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
❤️如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1125 Chain the Ropes

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-Mq2Q6ol2-1671843374397)(PAT 甲级辅导.assets/46293e57-aa0e-414b-b5c3-7c4b2d5201e2.jpg)]

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题意

给定 n 个绳子的长度,每两个绳子合并长度就会减少一半,需要求出所有绳子合并后长度的最大值,输出的是整数(向下取整)。

思路

绳子合并的顺序不同会导致最终的结果不同,例如有三根绳子 {1,2,3} ,如果想让前两个合并再和第三根合并,最终的绳子长度为 ((1+2)/2+3)/2=2.25 ;而如果先让第一根和第三根合并再和第二根合并,最终的绳子长度为 ((1+3)/2+2)/2=2

直接上结论,这其实有一点像哈夫曼树但又不完全相似,我们每次合并都去合并最小的那两根绳子,这样最后得到的长度一定是最大的。

代码

#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
double a[N];
int n;

int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> a[i];

    //进行排序
    sort(a, a + n);

    //计算最大长度并输出
    for (int i = 1; i < n; i++)    a[0] = (a[0] + a[i]) / 2;
    cout << (int)a[0] << endl;

    return 0;
}

相关文章:

  • 学Python上班第一天就翻车了?
  • Vue - npm 批量升级依赖包
  • Java编程实战21:构造字典序最大的合并字符串
  • java基于ssm,jsp鞋城源码卖鞋服装男鞋商城女鞋商城项目源码
  • java实现每日给女友微信发送早安等微信信息
  • Android设计模式详解之解释器模式
  • zabbix6.0安装教程(七):从web界面安装
  • 消息中间件Kafka快速入门
  • C#个人珍藏基础类库分享 — 9、基本排序算法类SortHelper
  • 提交 bug 的内容书写规范
  • 迅为3A5000开发板龙芯自主指令集从里到外100%全国产设计方案
  • 使用Postman进行自动化集成测试
  • 基于容器的PaaS混合云的几种形式
  • PS1文件执行
  • 力扣(LeetCode)187. 重复的DNA序列(C++)
  • 通过脚手架vue-cli创建一个vue项目
  • JS圣诞树
  • Linux 安装nginx, 搭建nginx文件服务器
  • [洛谷]P3613 【深基15.例2】寄包柜
  • 蓝桥杯-飞行员兄弟
  • 广西干旱程度有所缓解,未来一周旱情偏重地区降水量仍不足
  • 纪念|海上金石学的兴盛与王昶《金石萃编》
  • 马上评|演唱会云集,上海如何把“流量”变“留量”
  • 传染病防治法修订草案提请三审,拟加强医疗机构疾控能力建设
  • 清华成立人工智能医院,将构建“AI+医疗+教育+科研”闭环
  • 梅花画与咏梅诗